Back to overview
Degraded

Microsoft 365 outage affecting some connected accounts

Aug 31, 2026 at 9:28pm UTC
Affected services
MG WebDev support
MG WebDev Portal

Updated
Sep 1, 2026 at 1:08am UTC

We are continuing to investigate this issue.

Created
Aug 31, 2026 at 9:28pm UTC

Microsoft is reporting a service degradation affecting Microsoft 365 (Business and Enterprise), including Outlook and Exchange. As a result, some users can experience issues when accessing email accounts or when logging in with email.

This is an issue on Microsoft's side, not with MG WebDev Ltd. You can track Microsoft's progress here: https://status.cloud.microsoft

We'll update this status as the situation changes.