Back to overview
Downtime
cPanel is unavailable for some users
Feb 18, 2023 at 8:26am UTC
Resolved
Feb 18, 2023 at 10:02am UTC
This issue has been resolved.
Affected services
Updated
Feb 18, 2023 at 9:56am UTC
A fix has been implemented. We are now monitoring to see if the issue has been resolved.
Affected services
Updated
Feb 18, 2023 at 9:44am UTC
We have identified the root cause of the issue.
Affected services
Created
Feb 18, 2023 at 8:26am UTC
We are aware of the issue. We are actively working on it.
Affected services