Back to overview
Some Sites are offline
Aug 29, 2021 at 05:07pm UTC
Resolved
Aug 29, 2021 at 05:07pm UTC
Some sites that are hosted with MG WebDev are offline. We are now monitoring the issue
Affected services
Resolved
Aug 29, 2021 at 05:07pm UTC
Some sites that are hosted with MG WebDev are offline. We are now monitoring the issue
Affected services