Back to overview
Degraded

some parts of MG WebDev can't be reached

Feb 04 at 03:49pm CET
Affected services
MG WebDev support

Resolved
Feb 04 at 03:51pm CET

Our support website can now be reached at support.mgwebdev.eu

Created
Feb 04 at 03:49pm CET

Some parts of our support website can't be reached.