Back to overview
Degraded
Some emails are unavailable
Feb 04 at 08:41pm CET
Resolved
Feb 04 at 11:04pm CET
The issue has been fixed and all MG WebDev services are back online
Affected services
Updated
Feb 04 at 11:02pm CET
We have identified the issue and a fix is being implemented
Affected services
Created
Feb 04 at 08:41pm CET
Some email address domains are unavailable, users cant send emails to our emails ending with @mgwebdev.site.
Affected services