Back to overview
Degraded
Experiencing issues with MG WebDev Geneva, Switzerland - (GVA)
Jun 24 at 11:37am CEST
Resolved
Jun 24 at 01:05pm CEST
Due to lots of traffic on our server, it was working slower than normal. All services are now back online
Affected services
Created
Jun 24 at 11:37am CEST
We are currently experiencing issues with our server in Geneva, Switzerland - (GVA)
Affected services